RequirementsΒΆ

ContainDS Dashboards requires JupyterHub 1.0+ installed under Python 3.6+.

JupyterHub should ideally be configured with LocalProcessSpawner, SystemdSpawner, DockerSpawner, or KubeSpawner.

The Littlest JupyterHub (TLJH) is supported.

Zero to JupyterHub on Kubernetes is supported. Features available may depend on the persistent storage types available to you, as discussed in z2jh setup.

It is also possible to use your own custom installation of JupyterHub.